Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 04, 2026 - 15:00 UTC
Scheduled
Telna will be performing scheduled maintenance during this time. Expected Customer Impact: No customer service impact is expected. In the unlikely event of a brief interruption, traffic will be handled by existing redundancy mechanisms and services should automatically recover upon reattempt.
Posted Apr 29, 2026 - 15:07 UTC
This scheduled maintenance affected: Connectivity (CYTL02, CYTL10, CYTL25, CYTL26).