Third-Party Provider API Degradation & connectivity in USA

Incident Report for ConnectedYou

Resolved

This incident has been resolved.
Posted May 11, 2026 - 13:00 UTC

Monitoring

The issue has been identified and resolved, the services are now back up and working normally.
Posted May 11, 2026 - 12:43 UTC

Investigating

We are currently experiencing issues with a third-party provider integration and connectivity in the USA

As a result, actions related to SIMs associated with:

Provider: Telna
SIM profile prefix: CYTL

may currently fail or be unavailable.

Impacted operations include:

Activation
Suspension
Termination
SIM Reset
Online status checks

Our team is actively working with the provider to investigate and restore service functionality as soon as possible.

We will continue to provide updates as more information becomes available.

There are reportedly connectivity as well happening specifically in the USA
Posted May 11, 2026 - 12:15 UTC
This incident affected: IOT Orchestration Hub (console.connectedyou.io) (Connectivity Provider Integerations).